| Package | Affected versions | Patched versions |
|---|---|---|
| shopware/core | < 6.4.20.1 | 6.4.20.1 |
| shopware/platform | < 6.4.20.1 | 6.4.20.1 |
| shopware | = 6.5.0.0≥ 6.1.0, ≤ 6.4.20.0 |
We fixed with CVE-2023-22731 Twig filters to only be executed with allowed functions. It is possible to pass PHP Closures as string or an array and array crafted PHP Closures was not checked against allow list
The problem has been fixed with 6.4.20.1 with an improved override.
For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free