| Package | Affected versions | Patched versions |
|---|---|---|
| envoy | ≥ 1.23.0, < 1.23.6≥ 1.24.0, < 1.24.4≥ 1.25.0, < 1.25.3< 1.22.9 | 1.23.61.24.41.25.31.22.9 |
Envoy is an open source edge and service proxy designed for cloud-native applications. Compliant HTTP/1 service should reject malformed request lines. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, There is a possibility that non compliant HTTP/1 service may allow malformed requests, potentially leading to a bypass of security policies. This issue is fixed in versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free