요약
- CVE-2023-28447은(는) smarty/smarty, smarty (smarty)에 영향을 주는 보통 (CVSS 6.1) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.0%, 전체 취약점의 63.3%보다 높음.
- 조치: 4.3.1, 3.1.48 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.3.1< 3.1.48
| 4.3.13.1.48
|
| smarty | ≥ 4.0.0, < 4.3.1< 3.1.48
| 4.3.13.1.48
|
Description
Impact
An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user.
Patches
Please upgrade to the most recent version of Smarty v3 or v4.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
NVD description
Smarty is a template engine for PHP. In affected versions smarty did not properly escape javascript code. An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user. Users are advised to upgrade to either version 3.1.48 or to 4.3.1 to resolve this issue. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free