요약
- CVE-2023-36806은(는) contao/core-bundle, contao (contao)에 영향을 주는 보통 (CVSS 5.4) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.64%, 전체 취약점의 50.5%보다 높음.
- 조치: 4.9.42, 4.13.28, 5.1.10 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| contao/core-bundle Packagist | ≥ 4.0.0, < 4.9.42≥ 4.10.0, < 4.13.28≥ 5.0.0, < 5.1.10
| 4.9.424.13.285.1.10
|
| contao | ≥ 4.0.0, < 4.9.42≥ 4.10.0, < 4.13.28≥ 5.0.0, < 5.1.10
| 4.9.424.13.285.1.10
|
Description
Impact
Authenticated users can inject malicious code in widgets with units, which is then executed both in the element preview (back end) and on the website (front end).
Patches
Update to Contao 4.9.42, 4.13.28 or 5.1.10.
Workarounds
Disable login for all untrusted back end users.
References
https://contao.org/en/security-advisories/cross-site-scripting-in-widgets-with-units
For more information
If you have any questions or comments about this advisory, open an issue in contao/contao.
Credits
Thanks to Christian Pöschl and Fabian Brenner from usd AG for reporting this vulnerability.
NVD description
Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free