요약
- CVE-2023-39363은(는) vyper, vyper (vyperlang)에 영향을 주는 보통 (CVSS 5.9) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.82%, 전체 취약점의 57.3%보다 높음.
- 조치: 0.3.1 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| vyper PyPI | ≥ 0.2.15, < 0.3.1all versions
| 0.3.1
|
| vyper | = 0.2.15= 0.2.16= 0.3.0
| No fix yet |
Description
Impact
In versions 0.2.15, 0.2.16 and 0.3.0, named re-entrancy locks are allocated incorrectly. Each function using a named re-entrancy lock gets a unique lock regardless of the key, allowing cross-function re-entrancy in contracts compiled with the susceptible versions. A specific set of conditions is required to result in misbehavior of affected contracts, specifically:
- A
.vy contract compiled with either of the following vyper versions: 0.2.15, 0.2.16, 0.3.0
- A primary function that utilizes the
@nonreentrant decorator with a specific key and does not strictly follow the check-effects-interaction pattern (i.e. contains an external call to an untrusted party before storage updates)
- A secondary function that utilizes the same
key and would be affected by the improper state caused by the primary function
Patches
https://github.com/vyperlang/vyper/pull/2439, https://github.com/vyperlang/vyper/pull/2514
Workarounds
Upgrade to 0.3.1 or higher
References
Technical post-mortem report: https://hackmd.io/@vyperlang/HJUgNMhs2
NVD description
Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine (EVM). In versions 0.2.15, 0.2.16 and 0.3.0, named re-entrancy locks are allocated incorrectly. Each function using a named re-entrancy lock gets a unique lock regardless of the key, allowing cross-function re-entrancy in contracts compiled with the susceptible versions. A specific set of conditions is required to result in misbehavior of affected contracts, specifically: a `.vy` contract compiled with `vyper` versions `0.2.15`, `0.2.16`, or `0.3.0`; a primary function that utilizes the `@nonreentrant` decorator with a specific `key` and does not strictly follow the check-effects-interaction pattern (i.e. contains an external call to an untrusted party before storage updates); and a secondary function that utilizes the same `key` and would be affected by the improper state caused by the primary function. Version 0.3.1 contains a fix for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free