| Package | Affected versions | Patched versions |
|---|---|---|
| enterprise server | = 3.11.0≥ 3.10.0, < 3.10.4≥ 3.8.0, < 3.8.12≥ 3.9.0, < 3.9.7 | 3.10.43.8.123.9.7 |
Improper privilege management allowed arbitrary workflows to be committed and run using an improperly scoped PAT. To exploit this, a workflow must have already existed in the target repo. This vulnerability affected all versions of GitHub Enterprise Server since 3.8 and was fixed in version 3.8.12, 3.9.7, 3.10.4, and 3.11.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free