요약
- CVE-2024-24556은(는) urql (nearform), @urql/next에 영향을 주는 보통 (CVSS 6.1) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.36%, 전체 취약점의 29.2%보다 높음.
- 조치: 1.1.1 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| urql | < 1.1.1
| 1.1.1
|
| @urql/next npm | < 1.1.1
| 1.1.1
|
Description
impact
The @urql/next package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns html tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream.
To fix this vulnerability upgrade to version 1.1.1
NVD description
urql is a GraphQL client that exposes a set of helpers for several frameworks. The `@urql/next` package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns `html` tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream. To fix this vulnerability upgrade to version 1.1.1
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free