요약
- CVE-2024-2660은(는) github.com/hashicorp/vault, vault (hashicorp)에 영향을 주는 보통 (CVSS 6.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.30%, 전체 취약점의 23.1%보다 높음.
- 조치: 1.16.0, 1.14.11, 1.15.7 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | < 1.16.0
| 1.16.0
|
| vault | ≥ 1.14.0, < 1.14.11≥ 1.14.0, < 1.16.0≥ 1.15.0, < 1.15.7
| 1.14.111.16.01.15.7
|
Description
Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. Fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.
NVD description
Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. This vulnerability, CVE-2024-2660, affects Vault and Vault Enterprise 1.14.0 and above, and is fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.
github.com/hashicorp/vault의 다른 취약점
모두 보기 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free