요약
- CVE-2024-31208은(는) matrix-synapse, synapse (matrix)에 영향을 주는 보통 (CVSS 6.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.5%, 전체 취약점의 73.6%보다 높음.
- 조치: 1.105.1 이상으로 업데이트하세요.
Description
Impact
A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in how the auth chain cover index is calculated. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service.
Servers in private federations, or those that do not federate, are not affected.
Patches
Server administrators should upgrade to 1.105.1 or later.
Workarounds
One can:
- ban the malicious users or ACL block servers from the rooms; and/or
- leave the room and purge the room using the admin API
For more information
If you have any questions or comments about this advisory, please email us at security AT element.io.
NVD description
Synapse is an open-source Matrix homeserver. A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in the V2 state resolution algorithm. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service. Servers in private federations, or those that do not federate, are not affected. Server administrators should upgrade to 1.105.1 or later. Some workarounds are available. One can ban the malicious users or ACL block servers from the rooms and/or leave the room and purge the room using the admin API.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free