요약
- CVE-2024-37899은(는) org.xwiki.platform:xwiki-platform-oldcore, xwiki (xwiki)에 영향을 주는 높음 (CVSS 8.0) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.69%, 전체 취약점의 53.0%보다 높음.
- 조치: 14.10.21, 15.5.5, 15.10.6, 16.0.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| org.xwiki.platform:xwiki-platform-oldcore Maven | ≥ 13.10.3, < 14.10.21≥ 13.4.7, < 14.10.21≥ 15.0-rc-1, < 15.5.5≥ 15.6-rc-1, < 15.10.6≥ 16.0.0-rc-1, < 16.0.0
| 14.10.2115.5.515.10.616.0.0
|
| xwiki | = 13.4.7= 13.5= 16.0.0≥ 13.10.3, < 14.10.21≥ 15.0, < 15.5.5≥ 15.6, < 15.10.6
| 14.10.2115.5.515.10.6
|
Description
Impact
When an admin disables a user account, the user's profile is executed with the admin's rights. This allows a user to place malicious code in the user profile before getting an admin to disable the user account.
To reproduce, as a user without script nor programming rights, edit the about section of your user profile and add {{groovy}}services.logging.getLogger("attacker").error("Hello from Groovy!"){{/groovy}}.
As an admin, go to the user profile and click the "Disable this account" button.
Then, reload the page. If the logs show attacker - Hello from Groovy! then the instance is vulnerable.
Patches
This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0.
Workarounds
We're not aware of any workaround except upgrading.
References
NVD description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When an admin disables a user account, the user's profile is executed with the admin's rights. This allows a user to place malicious code in the user profile before getting an admin to disable the user account. To reproduce, as a user without script nor programming rights, edit the about section of your user profile and add `{{groovy}}services.logging.getLogger("attacker").error("Hello from Groovy!"){{/groovy}}`.
As an admin, go to the user profile and click the "Disable this account" button. Then, reload the page. If the logs show `attacker - Hello from Groovy!` then the instance is vulnerable. This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
### Workarounds
We're not aware of any workaround except upgrading.
### References
* https://jira.xwiki.org/browse/XWIKI-21611
* https://github.com/xwiki/xwiki-platform/commit/f89c8f47fad6e5cc7e68c69a7e0acde07f5eed5a
org.xwiki.platform:xwiki-platform-oldcore의 다른 취약점
모두 보기 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free