| Package | Affected versions | Patched versions |
|---|---|---|
| ckan | ≥ 2.7.0, < 2.10.5 | 2.10.5 |
| ckan | ≥ 2.7.0, < 2.10.5 | 2.10.5 |
The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector.
Sites running CKAN >= 2.7.0 with the datatables_view plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data.
This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0
Prevent importing of tabular files to the DataStore via DataPusher, XLoader,etc, at least those published from untrusted sources.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free