| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.zeppelin:zeppelin-shell | ≥ 0.11.1, < 0.12.0 | 0.12.0 |
| zeppelin | ≥ 0.11.0, < 0.12.0 | 0.12.0 |
Missing Origin Validation in WebSockets vulnerability in Apache Zeppelin.
The attacker could access the Zeppelin server from another origin without any restriction, and get internal information about paragraphs. This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0.
Users are recommended to upgrade to version 0.12.0, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free