요약
- CVE-2024-56201은(는) jinja2, jinja (palletsprojects)에 영향을 주는 높음 (CVSS 8.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.31%, 전체 취약점의 23.5%보다 높음.
- 조치: 3.1.5 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| jinja2 PyPI | ≥ 3.0.0, < 3.1.5
| 3.1.5
|
| jinja | ≥ 3.0.0, < 3.1.5
| 3.1.5
|
Description
A bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used.
To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename.
NVD description
Jinja is an extensible templating engine. In versions on the 3.x branch prior to 3.1.5, a bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used. To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename. This vulnerability is fixed in 3.1.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free