요약
- CVE-2025-47275은(는) auth0/auth0-php에 영향을 주는 심각 (CVSS 9.1) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.54%, 전체 취약점의 45.4%보다 높음.
- 조치: 8.14.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| auth0/auth0-php Packagist | ≥ 8.0.0-BETA1, < 8.14.0
| 8.14.0
|
Description
Overview
Session cookies of applications using the Auth0-PHP SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access.
Am I Affected?
You are affected by this vulnerability if you meet the following pre-conditions:
- Applications using the Auth0-PHP SDK, or the following SDKs that rely on the Auth0-PHP SDK:
a. Auth0/symfony,
b. Auth0/laravel-auth0,
c. Auth0/wordpress,
- Session storage configured with CookieStore.
Fix
Upgrade Auth0/Auth0-PHP to v8.14.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected.
Acknowledgement
Okta would like to thank Félix Charette for discovering this vulnerability.
NVD description
Auth0-PHP provides the PHP SDK for Auth0 Authentication and Management APIs. Starting in version 8.0.0-BETA1 and prior to version 8.14.0, session cookies of applications using the Auth0-PHP SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Certain pre-conditions are required to be vulnerable to this issue: Applications using the Auth0-PHP SDK, or the Auth0/symfony, Auth0/laravel-auth0, and Auth0/wordpress SDKs that rely on the Auth0-PHP SDK; and session storage configured with CookieStore. Upgrade Auth0/Auth0-PHP to v8.14.0 to receive a patch. As an additional precautionary measure, rotating cookie encryption keys is recommended. Note that once updated, any previous session cookies will be rejected.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free