요약
- CVE-2025-48947은(는) @auth0/nextjs-auth0에 영향을 주는 높음 (CVSS 7.7) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.43%, 전체 취약점의 37.8%보다 높음.
- 조치: 4.6.1 이상으로 업데이트하세요.
Description
Overview
In Auth0 Next.js SDK versions 4.0.1 to 4.6.0, __session cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers.
Am I Affected?
You are affected by this vulnerability if you meet the following preconditions:
- Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0,
- Applications using CDN or edge caching that caches responses with the Set-Cookie header.
- If the Cache-Control header is not properly set for sensitive responses.
Fix
Upgrade auth0/nextjs-auth0 to v4.6.1.
NVD description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In Auth0 Next.js SDK versions 4.0.1 through 4.6.0, `__session` cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers. Three preconditions must be met in order for someone to be affected by the vulnerability: Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0, applications using CDN or edge caching that caches responses with the Set-Cookie header, and if the Cache-Control header is not properly set for sensitive responses. Users should upgrade auth0/nextjs-auth0 to v4.6.1 to receive a patch.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free