| Package | Affected versions | Patched versions |
|---|---|---|
| contao/contao | ≥ 5.0.0, < 5.3.38≥ 5.4.0-RC1, < 5.6.1 | 5.3.385.6.1 |
| contao/core-bundle | ≥ 5.0.0, < 5.3.38≥ 5.4.0-RC1, < 5.6.1 | 5.3.385.6.1 |
| contao | ≥ 5.3.0, < 5.3.38≥ 5.4.0, < 5.6.1 | 5.3.385.6.1 |
The table access voter in the back end doesn't check if a user is allowed to access the corresponding module.
Update to Contao 5.3.38 or 5.6.1.
Do not rely solely on the voter and additionally check USER_CAN_ACCESS_MODULE.
If you have any questions or comments about this advisory, open an issue in contao/contao.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free