요약
- CVE-2025-58065은(는) flask-appbuilder, flask-appbuilder (dpgaspar)에 영향을 주는 보통 (CVSS 6.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.43%, 전체 취약점의 37.6%보다 높음.
- 조치: 4.8.1 이상으로 업데이트하세요.
Description
Impact
When Flask-AppBuilder is configured to use OAuth, LDAP, or other non-database authentication methods, the password reset endpoint remains registered and accessible, despite not being displayed in the user interface. This allows an enabled user to reset their password and be able to create JWT tokens even after the user is disabled on the authentication provider.
Patches
Upgrade to Flask-AppBuilder version 4.8.1 or later
Workarounds
If immediate upgrade is not possible:
- Manually disable password reset routes in the application configuration
- Implement additional access controls at the web server or proxy level to block access to the reset my password URL.
- Monitor for suspicious password reset attempts from disabled accounts
NVD description
Flask-AppBuilder is an application development framework. Prior to version 4.8.1, when Flask-AppBuilder is configured to use OAuth, LDAP, or other non-database authentication methods, the password reset endpoint remains registered and accessible, despite not being displayed in the user interface. This allows an enabled user to reset their password and be able to create JWT tokens even after the user is disabled on the authentication provider. Users should upgrade to Flask-AppBuilder version 4.8.1 or later to receive a fix. If immediate upgrade is not possible, manually disable password reset routes in the application configuration; implement additional access controls at the web server or proxy level to block access to the reset my password URL; and/or monitor for suspicious password reset attempts from disabled accounts.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free