요약
- CVE-2025-61676은(는) october/system, october (octobercms)에 영향을 주는 보통 (CVSS 4.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.27%, 전체 취약점의 19.8%보다 높음.
- 조치: 4.0.12, 3.7.13 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| october/system Packagist | ≥ 4.0.0, < 4.0.12< 3.7.13
| 4.0.123.7.13
|
| october | ≥ 4.0.0, < 4.0.12< 3.7.13
| 4.0.123.7.13
|
Description
A cross-site scripting (XSS) vulnerabilities was identified in October CMS backend configuration forms:
- Branding and Appearances Styles
A user with the Customize Backend Styles permission could inject malicious HTML/JS into the stylesheet input at
Settings → Branding & Appearance → Styles.
A specially crafted input could break out of the intended <style> context, allowing arbitrary script execution across backend pages for all users.
Impact
- Persistent XSS across the backend interface.
- Exploitable by lower-privileged accounts with the above permissions.
- Potential consequences include privilege escalation, session hijacking, and execution of unauthorized actions in victim sessions.
Patches
The vulnerability has been patched in v4.0.12 and v3.7.13.
Stylesheet inputs are now sanitized to prevent injection of arbitrary HTML/JS.
All users are strongly encouraged to upgrade to the latest patched version.
Workarounds
If upgrading immediately is not possible:
- Restrict the permissions
Customize Backend Styles to fully trusted administrators only.
This reduces exposure but does not fully eliminate risk.
Credits
NVD description
October is a Content Management System (CMS) and web platform. Prior to versions 3.7.13 and 4.0.12, a cross-site scripting (XSS) vulnerabilities was identified in October CMS backend configuration forms. A user with the Customize Backend Styles permission could inject malicious HTML/JS into the stylesheet input at Styles from Branding & Appearance settings. A specially crafted input could break out of the intended <style> context, allowing arbitrary script execution across backend pages for all users. This issue has been patched in versions 3.7.13 and 4.0.12.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free