요약
- CVE-2025-62374은(는) parse에 영향을 주는 보통 (CVSS 6.4) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.41%, 전체 취약점의 35.3%보다 높음.
- 조치: 7.0.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| parse npm | < 7.0.0
| 7.0.0
|
Description
Summary
Prototype pollution capabilities on various APIs.
Details
Injection of malicious payload allows attacker to remotely execute arbitrary code. Parse.Object and internal APIs are affected, specifically:
ParseObject.fromJSON
ParseObject.pin
ParseObject.registerSubclass
ObjectStateMutations (internal)
encode/decode (internal)
PoC
Demonstrative tests added as part of the fix.
References
NVD description
Parse Javascript SDK provides access to the powerful Parse Server backend from your JavaScript app. Prior to 7.0.0, injection of malicious payload allows attacker to remotely execute arbitrary code. ParseObject.fromJSON, ParseObject.pin, ParseObject.registerSubclass, ObjectStateMutations (internal), and encode/decode (internal) are affected. This vulnerability is fixed in 7.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free