요약
- CVE-2026-105867은(는) payload (payloadcms), @payloadcms/storage-s3에 영향을 주는 보통 (CVSS 6.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.22%, 전체 취약점의 12.6%보다 높음.
- 조치: 3.90.0, 4.0.0-canary.34 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| payload | = 4.0.0< 3.90.0
| 3.90.0
|
| @payloadcms/storage-s3 npm | ≥ 4.0.0-canary.0, < 4.0.0-canary.34< 3.90.0
| 4.0.0-canary.343.90.0
|
Description
Impact
An authenticated user could overwrite an existing S3 object belonging to another upload collection, bypassing that collection’s access controls and prior file validation.
You are affected if ALL of these are true:
- Client uploads are enabled for multiple collections that share an S3 bucket.
- useCompositePrefixes is not configured or is set to
false.
Patches
Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
Workarounds
Disable client uploads until you can upgrade.
NVD description
Payload is a free and open source headless content management system. In @payloadcms/storage-s3 versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user can overwrite an existing S3 object belonging to another upload collection when client uploads are enabled for multiple collections sharing a bucket and useCompositePrefixes is false or unset. This bypasses the target collection's access controls and prior file validation. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free