요약
- CVE-2026-23737은(는) seroval (lxsmnsyc), seroval에 영향을 주는 높음 (CVSS 7.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.58%, 전체 취약점의 47.8%보다 높음.
- 조치: 1.4.1 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| seroval | < 1.4.1
| 1.4.1
|
| seroval npm | < 1.4.1
| 1.4.1
|
Description
Improper input handling in the JSON deserialization component can lead to arbitrary JavaScript code execution.
The vulnerability can be exploited via overriding constant value and error deserialization, which allows indirect access to unsafe JS evaluation. This requires at least the ability to perform 4 separate requests on the same function and partial knowledge of how the serialized data is used during later runtime processing.
This vulnerability affects the fromJSON and fromCrossJSON functions in a client-to-server transmission scenario.
No known workarounds or mitigations are known, so please upgrade to the patched version.
NVD description
seroval facilitates JS value stringification, including complex structures beyond JSON.stringify capabilities. In versions 1.4.0 and below, improper input handling in the JSON deserialization component can lead to arbitrary JavaScript code execution. Exploitation is possible via overriding constant value and error deserialization, allowing indirect access to unsafe JS evaluation. At minimum, attackers need the ability to perform 4 separate requests on the same function, and partial knowledge of how the serialized data is used during later runtime processing. This vulnerability affects the fromJSON and fromCrossJSON functions in a client-to-server transmission scenario. This issue has been fixed in version 1.4.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free