요약
- CVE-2026-25055은(는) n8n (n8n), n8n에 영향을 주는 높음 (CVSS 8.1) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.9%, 전체 취약점의 79.2%보다 높음.
- 조치: 2.4.0f, 1.123.12, 2.4.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| n8n | ≥ 2.0.0, < 2.4.0f< 1.123.12
| 2.4.0f1.123.12
|
| n8n npm | ≥ 2.0.0, < 2.4.0< 1.123.12
| 2.4.01.123.12
|
Description
Impact
When workflows process uploaded files and transfer them to remote servers via the SSH node without validating their metadata the vulnerability can lead to files being written to unintended locations on those remote systems potentially leading to remote code execution on those systems.
As a prerequisites an unauthenticated attacker needs knowledge of such workflows existing and the endpoints for file uploads need to be unauthenticated.
Patches
The issue has been fixed in n8n version 2.4.0 and 1.123.12. Users should upgrade to this version or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Disable or restrict access to workflows that accept file uploads via webhooks and transfer them via SSH.
- Enable webhook authentication on all endpoints that handle file uploads.
- Review usage of SSH credentials and consider rotating SSH credentials if in doubt.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Resources
n8n has adopted CVSS 4.0 as primary score for all security advisories. CVSS 3.1 vector strings are provided for backwards compatibility.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
NVD description
n8n is an open source workflow automation platform. Prior to versions 1.123.12 and 2.4.0, when workflows process uploaded files and transfer them to remote servers via the SSH node without validating their metadata the vulnerability can lead to files being written to unintended locations on those remote systems potentially leading to remote code execution on those systems. As a prerequisites an unauthenticated attacker needs knowledge of such workflows existing and the endpoints for file uploads need to be unauthenticated. This issue has been patched in versions 1.123.12 and 2.4.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free