요약
- CVE-2026-27121은(는) svelte (svelte), svelte에 영향을 주는 보통 (CVSS 5.4) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.22%, 전체 취약점의 12.6%보다 높음.
- 조치: 5.51.5 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| svelte | < 5.51.5
| 5.51.5
|
| svelte npm | < 5.51.5
| 5.51.5
|
Description
Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers.
NVD description
svelte performance oriented web framework. Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers. This vulnerability is fixed in 5.51.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free