요약
- CVE-2026-27194은(는) dtale, d-tale (man)에 영향을 주는 심각 (CVSS 9.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.79%, 전체 취약점의 56.3%보다 높음.
- 조치: 3.20.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| dtale PyPI | < 3.20.0
| 3.20.0
|
| d-tale | ≤ 3.19.1
| No fix yet |
Description
Impact
Users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server.
Patches
Users should upgrade to version 3.20.0.
Workarounds
There are no workarounds for versions < 3.20.0
NVD description
D-Tale is a visualizer for pandas data structures. Versions prior to 3.20.0 are vulnerable to Remote Code Execution through the /save-column-filter endpoint. Users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server. This issue has been fixed in version 3.20.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free