요약
- CVE-2026-28804은(는) pypdf, pypdf (pypdf project)에 영향을 주는 보통 (CVSS 5.3) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.44%, 전체 취약점의 38.6%보다 높음.
- 조치: 6.7.5 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.7.5
| 6.7.5
|
| pypdf | < 6.7.5
| 6.7.5
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /ASCIIHexDecode filter.
Patches
This has been fixed in pypdf==6.7.5.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3666.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to version 6.7.5, an attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /ASCIIHexDecode filter. This issue has been patched in version 6.7.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free