요약
- CVE-2026-30226은(는) devalue (svelte), devalue에 영향을 주는 높음 (CVSS 7.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.42%, 전체 취약점의 35.9%보다 높음.
- 조치: 5.6.4 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| devalue | < 5.6.4
| 5.6.4
|
| devalue npm | < 5.6.4
| 5.6.4
|
Description
In devalue v5.6.3, devalue.parse and devalue.unflatten were susceptible to prototype pollution via maliciously crafted payloads. Successful exploitation could lead to Denial of Service (DoS) or type confusion.
NVD description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. In devalue v5.6.3 and earlier, devalue.parse and devalue.unflatten were susceptible to prototype pollution via maliciously crafted payloads. Successful exploitation could lead to Denial of Service (DoS) or type confusion. This vulnerability is fixed in 5.6.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free