| Package | Affected versions | Patched versions |
|---|---|---|
| craftcms/cms | ≥ 4.0.0-beta.1, < 4.17.4≥ 5.0.0-RC1, < 5.9.9 | 4.17.45.9.9 |
| craft cms | = 4.0.0= 5.0.0≥ 4.0.0.1, < 4.17.4≥ 5.0.1, < 5.9.9 | 4.17.45.9.9 |
A Remote Code Execution vulnerability exists in the Craft CMS 5 conditions system.
The BaseElementSelectConditionRule::getElementIds() method passes user-controlled string input
through renderObjectTemplate() -- an unsandboxed Twig rendering function with escaping disabled.
Any authenticated Control Panel user (including non-admin roles such as Author or Editor) can achieve full RCE by sending a crafted condition rule via standard element listing endpoints.
This vulnerability requires no admin privileges, no special permissions beyond basic control panel access, and bypasses all production hardening settings (allowAdminChanges: false, devMode: false, enableTwigSandbox: true).
Users should update to the patched 5.99 release to mitigate the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free