요약
- CVE-2026-33209은(는) avo, avo (avohq)에 영향을 주는 보통 (CVSS 6.1) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.27%, 전체 취약점의 19.1%보다 높음.
- 조치: 3.30.3 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| avo RubyGems | < 3.30.3
| 3.30.3
|
| avo | < 3.30.3
| 3.30.3
|
Description
Description
A reflected cross-site scripting (XSS) vulnerability exists in the return_to query parameter used in the avo interface.
An attacker can craft a malicious URL that injects arbitrary JavaScript, which is executed when he clicks a dynamically generated navigation button.
Impact
This vulnerability may allow execution of arbitrary JavaScript in the context of the application.
Impact varies depending on deployment:
- In unauthenticated setups: exploitable via crafted links sent to users
- In authenticated setups: limited to authenticated users and requires interaction
NVD description
Avo is a framework to create admin panels for Ruby on Rails apps. Prior to version 3.30.3, a reflected cross-site scripting (XSS) vulnerability exists in the return_to query parameter used in the avo interface. An attacker can craft a malicious URL that injects arbitrary JavaScript, which is executed when he clicks a dynamically generated navigation button. This issue has been patched in version 3.30.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free