요약
- CVE-2026-34052은(는) jupyterhub-ltiauthenticator, lti jupyterhub authenticator (jupyter)에 영향을 주는 보통 (CVSS 5.9) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.34%, 전체 취약점의 27.7%보다 높음.
- 조치: 1.6.3 이상으로 업데이트하세요.
Description
Summary
The LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service.
Patches
- upgrade jupyterhub-litauthenticator to 1.6.3
NVD description
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.
jupyterhub-ltiauthenticator의 다른 취약점
모두 보기 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free