요약
- CVE-2026-40293은(는) github.com/openfga/openfga, openfga (openfga)에 영향을 주는 보통 (CVSS 6.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.29%, 전체 취약점의 21.2%보다 높음.
- 조치: 1.14.0 이상으로 업데이트하세요.
Description
Description
When OpenFGA is configured to use preshared-key authentication with the built-in playground enabled, the local server includes the preshared API key in the HTML response of the /playground endpoint. The /playground endpoint is enabled by default and does not require authentication. It is intended for local development and debugging and is not designed to be exposed to production environments.
Am I Affected?
You are affected if you meet each of the following preconditions:
- You are running OpenFGA with --authn-method preshared, and
- The playground is enabled, and
- The playground endpoint is accessible beyond localhost or trusted networks.
Fix
Upgrade to OpenFGA v1.14.0, or disable the playground by running ./openfga run --playground-enabled=false.
NVD description
OpenFGA is an authorization/permission engine built for developers. In versions 0.1.4 through 1.13.1, when OpenFGA is configured to use preshared-key authentication with the built-in playground enabled, the local server includes the preshared API key in the HTML response of the /playground endpoint. The /playground endpoint is enabled by default and does not require authentication. It is intended for local development and debugging and is not designed to be exposed to production environments. Only those who run OpenFGA with `--authn-method` preshared, with the playground enabled, and with the playground endpoint accessible beyond localhost or trusted networks are vulnerable. To remediate the issue, users should upgrade to OpenFGA v1.14.0, or disable the playground by running `./openfga run --playground-enabled=false.`
github.com/openfga/openfga의 다른 취약점
모두 보기 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free