| Package | Affected versions | Patched versions |
|---|---|---|
| nextcloud server | ≥ 29.0.0, < 29.0.16.16≥ 30.0.0, < 30.0.17.9≥ 31.0.0, < 31.0.14.5≥ 32.0.0, < 32.0.9≥ 33.0.0, < 33.0.3 | 29.0.16.1630.0.17.931.0.14.532.0.933.0.3 |
Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, an authentication bypass vulnerability allowed attackers with knowledge of a user's password to circumvent two-factor authentication (2FA) protections. When a user initiated login with valid credentials on a 2FA-enabled account, the system created a temporary session token before enforcing the second factor challenge. This token could be extracted and replayed via HTTP Basic Authentication to gain unauthorized access to authenticated endpoints. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9 or 29.0.16.16
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free