요약
- CVE-2026-56353은(는) n8n (n8n), n8n에 영향을 주는 보통 (CVSS 4.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.33%, 전체 취약점의 26.2%보다 높음.
- 조치: 2.9.3, 1.123.22, 2.10.1 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| n8n | = 2.10.0≥ 2.0.0, < 2.9.3< 1.123.22
| 2.9.31.123.22
|
| n8n npm | ≥ 2.0.0, < 2.9.3≥ 2.10.0, < 2.10.1< 1.123.22
| 2.9.32.10.11.123.22
|
Description
Impact
When the Chat Trigger node is configured with n8n User Auth authentication, the authentication check could be circumvented.
- This issue requires the Chat Trigger node to be configured with n8n User Auth authentication (non-default).
Patches
The issue has been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Limit workflow creation and editing permissions to fully trusted users only.
- Use a different authentication method for the Chat Trigger node, or restrict network access to the webhook endpoint to trusted origins.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
NVD description
n8n contains an authentication bypass in the Chat Trigger node when configured with n8n User Auth (a non-default configuration). In affected releases — before 1.123.22, the 2.0.0 through 2.9.2 line, and 2.10.0 — the authentication check on the Chat Trigger webhook endpoint can be circumvented, allowing access without valid credentials. Fixed in 1.123.22, 2.9.3, and 2.10.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free