요약
- CVE-2026-57204은(는) pypdf, pypdf (pypdf project)에 영향을 주는 보통 (CVSS 6.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.37%, 전체 취약점의 30.6%보다 높음.
- 조치: 6.13.3 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.13.3
| 6.13.3
|
| pypdf | < 6.13.3
| 6.13.3
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage, as MAX_DECLARED_STREAM_LENGTH is sometimes ignored. This requires parsing a content stream without a /Length value.
Patches
This has been fixed in pypdf==6.13.3.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3871.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.13.3, a maliciously crafted PDF can cause DoS. An attacker who uses this vulnerability can craft a PDF which leads to large memory usage, as MAX_DECLARED_STREAM_LENGTH is sometimes ignored. This requires parsing a content stream without a /Length value. This issue has been fixed in version 6.13.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free