요약
- CVE-2026-77078은(는) multer (expressjs), multer에 영향을 주는 높음 (CVSS 7.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.49%, 전체 취약점의 42.1%보다 높음.
- 조치: 2.3.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| multer | < 2.3.0
| 2.3.0
|
| multer npm | < 2.3.0
| 2.3.0
|
Description
Impact
A vulnerability in multer allows a remote, unauthenticated attacker to crash the Node.js process with a single multipart/form-data request. Two specially crafted text field names cause an uncaught RangeError: Invalid array length inside multer's field parsing, which is not routed to the application error handler and terminates the process. All applications using multer to parse multipart requests are affected.
Patches
Users should upgrade to 2.3.0.
Workarounds
None.
NVD description
multer is a middleware for handling multipart/form-data in Node.js. A small multipart request containing two specially crafted text field names can cause an uncaught RangeError (Invalid array length) that terminates the Node.js process. The first field uses a very large numeric array index to allocate a maximum-length sparse array, and a second field then pushes past that length, which throws inside the append-field dependency and is not caught by multer. All versions before 2.3.0 are affected, and the issue is a remotely triggerable denial of service. The issue is fixed in multer 2.3.0. Upgrade to multer 2.3.0 to remediate.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free