요약
- CVE-2026-81176은(는) devalue에 영향을 주는 보통 (CVSS 5.3) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.51%, 전체 취약점의 43.2%보다 높음.
- 조치: 5.9.2 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| devalue npm | < 5.9.2
| 5.9.2
|
Description
Impact
devalue.parse prior to version 5.9.2 fails to reject out-of-bounds indices. Specially-crafted payloads can exploit this to cause devalue to alternate between different array representations, resulting in work that is quadratic with payload size.
Applications are potentially affected if they call devalue.parse with untrusted data.
Patches
The bug is fixed in [email protected].
NVD description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. Prior to 5.9.2, devalue.parse does not reject out-of-bounds indices that are greater than or equal to values.length in src/parse.js. A specially crafted untrusted payload can make the parser alternate between array representations, producing quadratic work as the payload grows and causing denial of service in applications that parse untrusted devalue data. This issue is fixed in version 5.9.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free