| Package | Affected versions | Patched versions |
|---|---|---|
| next | ≥ 0.9.9, < 5.1.0 | 5.1.0 |
Versions of next prior to 5.1.0 are vulnerable to Remote Code Execution. The /path: route fails to properly sanitize input and passes it to a require() call. This allows attackers to execute JavaScript code on the server. Note that prior version 0.9.9 package next npm package hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions.
Upgrade to version 5.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free