Em resumo
- CVE-2013-6393 é uma vulnerabilidade MÉDIO (CVSS 6.8) que afeta libyaml (pyyaml), openstack (redhat), libyaml.
- Chance de exploração nos próximos 30 dias (EPSS): 7.4%, maior que 94.4% das vulnerabilidades.
- Correção: atualize para 0.2.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| libyaml | = 0.0.1= 0.1.1= 0.1.2= 0.1.3≤ 0.1.4
| No fix yet |
| openstack | = 3.0= 4.0
| No fix yet |
| libyaml npm | < 0.2.3
| 0.2.3
|
Description
Versions 0.2.2 and earlier depend on native libyaml version 0.1.5 or earlier. As such, they are affected by a heap-based buffer overflow vulnerability that may result in a crash or arbitrary code execution when parsing YAML tags.
Recommendation
- Update to version 0.2.3 that includes a version of LibYAML that contains a fix for this issue.
NVD description
The yaml_parser_scan_tag_uri function in scanner.c in LibYAML before 0.1.5 performs an incorrect cast, which allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted tags in a YAML document, which triggers a heap-based buffer overflow.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free