Em resumo
- CVE-2014-3743 é uma vulnerabilidade MÉDIO (CVSS 6.1) que afeta marked (marked project), marked.
- Chance de exploração nos próximos 30 dias (EPSS): 1.7%, maior que 77.5% das vulnerabilidades.
- Correção: atualize para 0.3.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| marked | < 0.3.1
| 0.3.1
|
| marked npm | < 0.3.1
| 0.3.1
|
Description
Versions 0.3.0 and earlier of marked are affected by two cross-site scripting vulnerabilities, even when sanitize: true is set.
The attack vectors for this vulnerability are GFM Codeblocks and JavaScript URLs.
Recommendation
Upgrade to version 0.3.1 or later.
NVD description
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free