Em resumo
- CVE-2015-9236 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta hapi (hapijs), hapi.
- Chance de exploração nos próximos 30 dias (EPSS): 1.5%, maior que 74.5% das vulnerabilidades.
- Correção: atualize para 11.0.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| hapi | < 11.0.0
| 11.0.0
|
| hapi npm | < 11.0.0
| 11.0.0
|
Description
Versions of hapi prior to 11.0.0 implement CORS incorrectly, allowing for configurations that at best return inconsistent headers, and at worst allow cross-origin activities that are expected to be forbidden.
If the connection has CORS enabled but one route has it off, and the route is not GET, the OPTIONS prefetch request will return the default CORS headers and then the actual request will go through and return no CORS headers. This defeats the purpose of turning CORS on the route.
Recommendation
Update to version 11.0.0 or later.
NVD description
Hapi versions less than 11.0.0 implement CORS incorrectly and allowed for configurations that at best returned inconsistent headers and at worst allowed cross-origin activities that were expected to be forbidden. If the connection has CORS enabled but one route has it off, and the route is not GET, the OPTIONS prefetch request will return the default CORS headers and then the actual request will go through and return no CORS headers. This defeats the purpose of turning CORS on the route.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free