Em resumo
- CVE-2016-20018 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta knex (knexjs), knex.
- Chance de exploração nos próximos 30 dias (EPSS): 1.1%, maior que 66.3% das vulnerabilidades.
- Correção: atualize para 2.4.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| knex | ≤ 2.3.0
| No fix yet |
| knex npm | < 2.4.0
| 2.4.0
|
Description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.
NVD description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free