Em resumo
- CVE-2016-2515 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta hawk (hawk project), hawk.
- Chance de exploração nos próximos 30 dias (EPSS): 3.4%, maior que 88.8% das vulnerabilidades.
- Correção: atualize para 4.1.1, 3.1.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| hawk | = 3.1.2= 4.1.0
| No fix yet |
| hawk npm | ≥ 4.0.0, < 4.1.1< 3.1.3
| 4.1.13.1.3
|
Description
Versions of hawk prior to 3.1.3, or 4.x prior to 4.1.1 are affected by a regular expression denial of service vulnerability related to excessively long headers and URI's.
Recommendation
Update to hawk version 4.1.1 or later.
NVD description
Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free