Em resumo
- CVE-2017-16007 é uma vulnerabilidade MÉDIO (CVSS 5.9) que afeta node-jose (cisco), node-jose.
- Chance de exploração nos próximos 30 dias (EPSS): 0.91%, maior que 60.1% das vulnerabilidades.
- Correção: atualize para 0.9.3 ou posterior.
Description
Affected versions of node-jose are vulnerable to an invalid curve attack. This allows an attacker to recover the private secret key when JWE with Key Agreement with Elliptic Curve Diffie-Hellman Ephemeral Static (ECDH-ES) is used.
Proof of Concept
Recommendation
Update to version 0.9.3 or later.
NVD description
node-jose is a JavaScript implementation of the JSON Object Signing and Encryption (JOSE) for current web browsers and node.js-based servers. node-jose earlier than version 0.9.3 is vulnerable to an invalid curve attack. This allows an attacker to recover the private secret key when JWE with Key Agreement with Elliptic Curve Diffie-Hellman Ephemeral Static (ECDH-ES) is used.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free