Em resumo
- CVE-2017-16042 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta growl (growl project), growl.
- Chance de exploração nos próximos 30 dias (EPSS): 4.6%, maior que 91.7% das vulnerabilidades.
- Correção: atualize para 1.10.2, 1.10.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| growl | < 1.10.2
| 1.10.2
|
| growl npm | < 1.10.0
| 1.10.0
|
Description
Affected versions of growl do not properly sanitize input prior to passing it into a shell command, allowing for arbitrary command execution.
Recommendation
Update to version 1.10.0 or later.
NVD description
Growl adds growl notification support to nodejs. Growl before 1.10.2 does not properly sanitize input before passing it to exec, allowing for arbitrary command execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free