Em resumo
- CVE-2017-16111 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta content (content project), content.
- Chance de exploração nos próximos 30 dias (EPSS): 1.1%, maior que 65.9% das vulnerabilidades.
- Correção: atualize para 3.0.7 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| content | ≤ 3.0.5
| No fix yet |
| content npm | < 3.0.7
| 3.0.7
|
Description
Affected versions of content are vulnerable to a regular expression denial of service when parsing malicious Content-Type and Content-Disposition headers.
Recommendation
Update to version 3.0.6 or later.
NVD description
The content module is a module to parse HTTP Content-* headers. It is used by the hapijs framework to provide this functionality. The module is vulnerable to regular expression denial of service when passed a specifically crafted Content-Type or Content-Disposition header.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free