Em resumo
- CVE-2017-16118 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta forwarded (forwarded project), forwarded.
- Chance de exploração nos próximos 30 dias (EPSS): 1.9%, maior que 79.3% das vulnerabilidades.
- Correção: atualize para 0.1.2 ou posterior.
Description
Affected versions of forwarded are vulnerable to regular expression denial of service when parsing specially crafted user input.
Recommendation
Update to version 0.1.2 or later
NVD description
The forwarded module is used by the Express.js framework to handle the X-Forwarded-For header. It is vulnerable to a regular expression denial of service when it's passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free