Em resumo
- CVE-2017-16119 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta fresh (fresh project), fresh.
- Chance de exploração nos próximos 30 dias (EPSS): 1.6%, maior que 75.6% das vulnerabilidades.
- Correção: atualize para 0.5.2 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| fresh | < 0.5.2
| 0.5.2
|
| fresh npm | < 0.5.2
| 0.5.2
|
Description
Affected versions of fresh are vulnerable to regular expression denial of service when parsing specially crafted user input.
Recommendation
Update to version 0.5.2 or later.
NVD description
Fresh is a module used by the Express.js framework for HTTP response freshness testing. It is vulnerable to a regular expression denial of service when it is passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free