Em resumo
- CVE-2018-1000534 é uma vulnerabilidade MÉDIO (CVSS 6.1) que afeta joplin (joplin project), joplin.
- Chance de exploração nos próximos 30 dias (EPSS): 1.5%, maior que 74.4% das vulnerabilidades.
- Correção: atualize para 1.0.90 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| joplin | < 1.0.90
| 1.0.90
|
| joplin npm | < 1.0.90
| 1.0.90
|
Description
Joplin version prior to 1.0.90 contains a Cross-site Scripting (XSS) evolving into code execution due to enabled nodeIntegration for that particular BrowserWindow instance where XSS was identified from vulnerability in Note content field - information on the fix can be found here https://github.com/laurent22/joplin/commit/494e235e18659574f836f84fcf9f4d4fcdcfcf89 that can result in executing unauthorized code within the rights in which the application is running. This attack appear to be exploitable via Victim synchronizing notes from the cloud services or other note-keeping services which contain malicious code. This vulnerability appears to have been fixed in 1.0.90 and later.
NVD description
Joplin version prior to 1.0.90 contains a XSS evolving into code execution due to enabled nodeIntegration for that particular BrowserWindow instance where XSS was identified from vulnerability in Note content field - information on the fix can be found here https://github.com/laurent22/joplin/commit/494e235e18659574f836f84fcf9f4d4fcdcfcf89 that can result in executing unauthorized code within the rights in which the application is running. This attack appear to be exploitable via Victim synchronizing notes from the cloud services or other note-keeping services which contain malicious code. This vulnerability appears to have been fixed in 1.0.90 and later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free