Em resumo
- CVE-2018-1002203 é uma vulnerabilidade MÉDIO (CVSS 5.5) que afeta unzipper (unzipper project), unzipper.
- Chance de exploração nos próximos 30 dias (EPSS): 10.6%, maior que 95.8% das vulnerabilidades.
- Correção: atualize para 0.8.13 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| unzipper | < 0.8.13
| 0.8.13
|
| unzipper npm | < 0.8.13
| 0.8.13
|
Description
Versions of unzipper before 0.8.13 are vulnerable to arbitrary file write when used to extract a specifically crafted archive that contains path traversal filenames (../../file.txt for example).
Recommendation
Update to version 0.3.18 or later.
NVD description
unzipper npm library before 0.8.13 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free