Em resumo
- CVE-2018-3715 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta glance (glance project), glance.
- Chance de exploração nos próximos 30 dias (EPSS): 1.5%, maior que 73.6% das vulnerabilidades.
- Correção: atualize para 3.0.4 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| glance | < 3.0.4
| 3.0.4
|
| glance npm | < 3.0.4
| 3.0.4
|
Description
Versions of glance before 3.0.4 are vulnerable to a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Recommendation
Update to version 3.0.4 or later.
NVD description
glance node module before 3.0.4 suffers from a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free