Em resumo
- CVE-2018-3720 é uma vulnerabilidade ALTO (CVSS 8.8) que afeta assign-deep (assign-deep project), assign-deep.
- Chance de exploração nos próximos 30 dias (EPSS): 2.0%, maior que 80.7% das vulnerabilidades.
- Correção: atualize para 0.4.7 ou posterior.
Description
Versions of assign-deep before 0.4.7 are vulnerable to prototype pollution via merging functions.
Recommendation
Update to version 0.4.7 or later.
NVD description
assign-deep node module before 0.4.7 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free